The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


Basket

TopicsRepliesAuthorViewsLast Posts
No new posts  Announcement:  MK4 boards are back !! 0tubes4hifi1010View latest post on Tue Nov 14, 2017 1:29 pm
by tubes4hifi
No new posts  Announcement:  PAS3 preamp upgrades & modifications 1tubes4hifi5628View latest post on Fri Jun 30, 2017 12:43 am
by erhard-audio
No new posts   7199 Board to 6GH8 Board Question 2scsidude24485View latest post on Tue Jul 13, 2010 11:28 am
by GP49
No new posts   A stepped attenuator for your ST-70/ST-120 20Bob Latino10016View latest post on Mon Jul 12, 2010 1:50 pm
by janka
No new posts   passive preamps 2earless1456View latest post on Tue Jul 06, 2010 4:47 pm
by GP49
No new posts   Distortion/noise on newly modded PAS3 3fromans41065View latest post on Mon Jul 05, 2010 3:16 am
by fromans4
No new posts   Cooler Summer Amp.. 0Sled108785View latest post on Mon Jul 05, 2010 1:13 am
by Sled108
No new posts   Faint Sizzling Noise (both channels) 3Avitar1651View latest post on Sun Jul 04, 2010 10:51 am
by Bob Latino
No new posts   GZ37 in st70: Results 3Corona2084View latest post on Mon Jun 28, 2010 2:09 pm
by Bob Latino
No new posts   new to me 2 pat-5's 1natoe719View latest post on Fri Jun 25, 2010 1:10 pm
by Bob Latino
No new posts    "upscale" parts for Dynaco ST-35 1Captain Coconut1127View latest post on Fri Jun 25, 2010 7:28 am
by howardnair
No new posts   Passive Preamp for VTA ST70 1Riddler1527View latest post on Thu Jun 24, 2010 7:41 pm
by RockyAM
No new posts   Test Bench Suggestions 2scsidude21326View latest post on Mon Jun 21, 2010 4:35 pm
by Bob Latino
No new posts   PAS back panel rewire 7PeterCapo1663View latest post on Mon Jun 21, 2010 10:50 am
by PeterCapo
No new posts   Vibrating Tubes 3scsidude22041View latest post on Thu Jun 17, 2010 12:34 pm
by Bob Latino
No new posts   pas2/3 transformer 3howardnair2544View latest post on Thu Jun 17, 2010 12:08 pm
by PeterCapo
No new posts   A little different 0scsidude2786View latest post on Tue Jun 15, 2010 9:13 pm
by scsidude2
No new posts   Splitting cathode resistors in Dynaco tube amps 0GP492552View latest post on Tue Jun 15, 2010 1:01 am
by GP49
No new posts   Replacing Selector Switch on PAS 3 2jerdobi2902View latest post on Mon Jun 14, 2010 12:14 pm
by GP49
No new posts   PRE-AMP HUM 4RMG1548View latest post on Sun Jun 13, 2010 2:40 pm
by RMG
No new posts   Effects of increased Capacitor voltage 4scsidude21883View latest post on Sat Jun 12, 2010 3:47 pm
by Bob Latino
No new posts   sds cap board st 70 mod 2Dave1587View latest post on Tue Jun 08, 2010 9:23 pm
by Dave
No new posts   Switching the triode-pentode switches while the amp is running 1RockyAM2550View latest post on Sun Jun 06, 2010 12:49 pm
by Bob Latino
No new posts   Best place to buy new KT66's? 9xlr87538View latest post on Sun Jun 06, 2010 7:40 am
by kevco
No new posts   Tung Sol KT-120 's 1baddog19462663View latest post on Fri Jun 04, 2010 5:03 pm
by Bob Latino
No new posts   Choke C-354 in Dynaco ST-70? 0ViperZ8882View latest post on Thu Jun 03, 2010 4:50 pm
by ViperZ
No new posts   great tube deal on Tung Sol KT-120 7baddog19462659View latest post on Thu Jun 03, 2010 4:23 pm
by RichJB603
No new posts   GZ37 in st70? 6Corona2871View latest post on Thu Jun 03, 2010 12:35 am
by Corona
No new posts   Dynaco PAS Pictorial Diagram 1jerdobi2039View latest post on Mon May 31, 2010 12:27 pm
by Bob Latino
No new posts   Low Gain Humm With My st70 & jolida envoy preamp 2Carl1489View latest post on Fri May 28, 2010 4:17 pm
by Carl
No new posts   advice on tubes for Mark IV 1tubenewb869View latest post on Thu May 27, 2010 7:07 am
by Bob Latino
No new posts   Tube Rolling with the ST120 4Reid2969View latest post on Tue May 25, 2010 12:38 pm
by GP49
No new posts   new mark 3 boards. 2natoe1276View latest post on Sun May 23, 2010 5:02 pm
by Sal
No new posts   SP6-PAS3-Z Kit 6fromans42468View latest post on Sun May 23, 2010 5:28 am
by fromans4
No new posts   Tube amp frauds on Ebay 4kevco2664View latest post on Wed May 19, 2010 3:28 pm
by avi.inc
No new posts   mark 3 questions 4natoe5040View latest post on Wed May 19, 2010 11:32 am
by tubes4hifi
No new posts   The Old A-470's cloth lead vs. new production outputs ... 7wolverine4881View latest post on Tue May 18, 2010 6:30 pm
by viridian
No new posts   tung sol KT120 2baddog19462294View latest post on Mon May 17, 2010 9:28 pm
by baddog1946
No new posts   PAS 3 Phono board question 1willemakeit971View latest post on Sun May 16, 2010 11:09 pm
by Bob Latino
No new posts   ST-70 test voltages need diagnosis 1Aljaheejus865View latest post on Sun May 16, 2010 6:39 pm
by Bob Latino
No new posts   ST-70 channel cutting out 10Aljaheejus2004View latest post on Sun May 16, 2010 4:04 pm
by Bob Latino
No new posts   Cap upgrades on VTA boards 16Brent704118View latest post on Sat May 15, 2010 2:53 pm
by Bob Latino
No new posts   thermistor? 1natoe2743View latest post on Wed May 12, 2010 3:25 pm
by Luddite
No new posts   Weird KT66 problems... 3Corona2195View latest post on Tue May 11, 2010 8:56 pm
by avi.inc
No new posts   Is anyone using fast recovery diodes in a VTA 70 or PAS? 2viridian2979View latest post on Sat May 08, 2010 11:34 am
by viridian
No new posts   Newbie question about upgrading a PAS 3 line amplifer only. 1Guest1544View latest post on Sat May 08, 2010 9:40 am
by Bob Latino
No new posts   st-70 balance bias control kit 2natoe1777View latest post on Thu May 06, 2010 8:57 pm
by natoe
No new posts   lowering gain on hi-gain VTA 2LEVLHED1216View latest post on Wed May 05, 2010 3:27 pm
by LEVLHED
No new posts   High gain or low gain version of ST-70 board, guidance needed. 5viridian1562View latest post on Sun May 02, 2010 1:01 pm
by viridian
No new posts   k40-y caps 1kost1651View latest post on Sun May 02, 2010 7:24 am
by Bob Latino
No new posts   clone with one side not right 9natoe1062View latest post on Fri Apr 30, 2010 7:50 am
by wolverine
No new posts   VTA driver board - resistors over-heating? 13dyna701798View latest post on Tue Apr 27, 2010 11:10 am
by dyna70
Moderators
None
Permissions in this forum:
You cannot post new topics in this forum
You cannot reply to topics in this forum

Users browsing this forum: 2 Registered, 0 Hidden and 6 Guests

Registered Users: mikej497, stewdan


  • New posts New posts
  • No new posts No new posts
  • New posts [ Popular ] New posts [ Popular ]
  • No new posts [ Popular ] No new posts [ Popular ]
  • New posts [ Locked ] New posts [ Locked ]
  • No new posts [ Locked ] No new posts [ Locked ]
  • Announcement Announcement
  • Sticky Sticky
  • Global announcement Global announcement
Current date/time is Thu Apr 26, 2018 6:43 pm