The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


Basket

TopicsRepliesAuthorViewsLast Posts
No new posts  Announcement:  PAS3 preamp upgrades & modifications 1tubes4hifi6845View latest post on Fri Jun 30, 2017 12:43 am
by erhard-audio
No new posts   Pros and cons of using solid state rectifiers in Dynaco amps ? 11Dynaluva10039View latest post on Sun Nov 22, 2009 2:45 pm
by vegaseddoc
No new posts   GSI board I need a parts list and any diagram's 4Tanner1171View latest post on Sat Nov 21, 2009 8:42 pm
by Tanner
No new posts   vta resistors 4kost2193View latest post on Wed Nov 18, 2009 5:27 pm
by Brinkman
No new posts   Another Stereo 70 Resto-Mod Completed 15tomlang4684View latest post on Wed Nov 18, 2009 4:11 pm
by Brinkman
No new posts   Star Grounding Scheme Observations and Questions 5tomlang6184View latest post on Sun Nov 15, 2009 11:04 am
by Bob Latino
No new posts   VTA PARTS UPGRADE 1kost2144View latest post on Wed Nov 11, 2009 10:42 am
by tomlang
No new posts   My ST-35 Build............. 3atwageman1310View latest post on Tue Nov 10, 2009 5:17 pm
by atwageman
No new posts   Nailing down bias... 16kevco5905View latest post on Wed Nov 04, 2009 12:40 pm
by GP49
No new posts   Assembled kits and 4 ohm speakers? 3LEVLHED1252View latest post on Wed Oct 28, 2009 9:26 am
by Bob Latino
No new posts   The height of Audio Voodoo 04MarkNY933View latest post on Sun Oct 25, 2009 8:03 pm
by 4MarkNY
No new posts   Black Sable EL34's for VTA ST-70 ? 1RockyAM4334View latest post on Sun Oct 25, 2009 10:41 am
by Bob Latino
No new posts   Tubes4HiFi 587uF Power Supply Board for PAS 2PeterCapo2105View latest post on Thu Oct 22, 2009 4:20 pm
by PeterCapo
No new posts   New JJ ECC99 preamp tube 1Bugs3582View latest post on Sat Oct 17, 2009 1:57 pm
by Bugs
No new posts   ST 70 Sproing 4Bugs1126View latest post on Sat Oct 17, 2009 12:20 am
by Bugs
No new posts   Lost left channel on St-70 84MarkNY3251View latest post on Fri Oct 16, 2009 8:18 am
by 4MarkNY
No new posts   Standby switch for ST-120 1THOR-IUM1551View latest post on Sun Oct 11, 2009 8:25 am
by Bob Latino
No new posts   PAS 3 Output Impedance 1myaddiction2202View latest post on Wed Oct 07, 2009 11:19 pm
by GP49
No new posts   Unbiased opinion about KT 66 10Tube Nube2850View latest post on Tue Sep 22, 2009 2:18 pm
by Tube Nube
No new posts   ST70 PA60 Transformers 3Bugs2109View latest post on Fri Sep 18, 2009 11:18 pm
by Bob Latino
No new posts   RMAF October 2-4, 2009 0Listens2tubes802View latest post on Sun Sep 13, 2009 2:29 pm
by Listens2tubes
No new posts   A great Dynaco Day! 9Sal2604View latest post on Sun Sep 13, 2009 2:15 pm
by Listens2tubes
No new posts   Stereophile Magazine's 1992 Review of The Panor Built Dynaco ST70 II 7kevco4021View latest post on Sat Sep 12, 2009 10:03 pm
by GP49
No new posts   ST-70 Mono Configuration and Quadaptors 8quadaptor1669View latest post on Sun Sep 06, 2009 12:17 am
by Listens2tubes
No new posts   SCA- 35 Tube Rolling Suggestions 4myounger19302368View latest post on Wed Sep 02, 2009 6:19 pm
by Tube Nube
No new posts   Dynakit Mark 3 cage and Dynaco Mark 2 chassis and bottom cover wanted 3hatrack711671View latest post on Wed Aug 26, 2009 7:44 pm
by Bob Latino
No new posts   Mk III won't bias properly 3aliveatfive5686View latest post on Wed Aug 26, 2009 7:37 pm
by Bob Latino
No new posts   2 quick newbie questions 2Normster859View latest post on Wed Aug 26, 2009 7:22 pm
by Normster
No new posts   J. Gordon Holt has died 4GP491694View latest post on Tue Aug 25, 2009 1:00 am
by GP49
No new posts   PAS-3 upgrades 10tubes4hifi9034View latest post on Mon Aug 24, 2009 11:13 am
by Tube Nube
No new posts   WHERE TO FIND CHASSIS BIAS PINS? HELP 2CarlB1251View latest post on Sat Aug 22, 2009 2:27 am
by tubes4hifi
No new posts   New to the forum: guidance needed 11Yvon Massicotte1460View latest post on Thu Aug 13, 2009 6:58 pm
by GP49
No new posts   please help to find a cage for my st 70 1al canonigo1231View latest post on Mon Aug 10, 2009 9:04 pm
by Bob Latino
No new posts   5U4GB instead of 5AR4 in my ST70 2myaddiction3415View latest post on Sat Aug 08, 2009 9:00 pm
by Bob Latino
No new posts   3-wire Grounding schemes 3JunkyJan1948View latest post on Tue Aug 04, 2009 5:49 pm
by GP49
No new posts   ST70 and Speakers 12Bugs5266View latest post on Mon Jul 27, 2009 2:56 pm
by kevco
No new posts   replacing a 40k pot with a 50k pot 4duder19821099View latest post on Wed Jul 22, 2009 9:35 pm
by duder1982
No new posts   EDICRON EL34s?? 3GP493162View latest post on Sun Jul 19, 2009 10:52 am
by kevco
No new posts   ST70s as Mono Blocks 19Bugs2878View latest post on Sat Jul 18, 2009 10:55 am
by Bugs
No new posts   Lights are on but nobody's home 8Bugs1104View latest post on Fri Jul 17, 2009 10:52 am
by Bugs
No new posts   Dynaco FM-3 pictorials now available on 7 jpeg files 4Bob Latino2146View latest post on Wed Jul 08, 2009 12:26 pm
by Bob Latino
No new posts   Colored wire 4hup_d_dup1203View latest post on Wed Jul 08, 2009 8:46 am
by hup_d_dup
No new posts   HIgh Gain VTA Board Change Tubes for Lower Gain 1myaddiction1481View latest post on Sat Jul 04, 2009 8:20 pm
by Bob Latino
No new posts   unstable bias voltage 3leo12542235View latest post on Fri Jul 03, 2009 6:11 pm
by Sal
No new posts   Blown fuse ... what now? 17hup_d_dup3775View latest post on Thu Jul 02, 2009 9:28 am
by Bob Latino
No new posts   How would you Modify a MK III to use EL156 tube ? 3Tazsmonn1415View latest post on Tue Jun 23, 2009 4:48 pm
by GP49
No new posts   Mk II ... Mk III 4hup_d_dup2919View latest post on Fri Jun 12, 2009 11:39 am
by GP49
No new posts   Funky National branded 7199 tube 3Sal6190View latest post on Mon Jun 08, 2009 5:09 pm
by Tazsmonn
No new posts   Odd, low level hum, Dynaco Mk II 10GP494423View latest post on Wed Jun 03, 2009 5:37 pm
by GP49
No new posts   Observations and Questions VTA Board for ST70 1myaddiction3757View latest post on Sun May 31, 2009 10:34 pm
by Bob Latino
No new posts   Pack Dynaco amps carefully - photos ... 4Bob Latino1512View latest post on Fri May 29, 2009 1:33 pm
by tubes4hifi
Moderators
None
Permissions in this forum:
You cannot post new topics in this forum
You cannot reply to topics in this forum

Users browsing this forum: 1 Registered, 0 Hidden and 3 Guests

Registered Users: pichacker


  • New posts New posts
  • No new posts No new posts
  • New posts [ Popular ] New posts [ Popular ]
  • No new posts [ Popular ] No new posts [ Popular ]
  • New posts [ Locked ] New posts [ Locked ]
  • No new posts [ Locked ] No new posts [ Locked ]
  • Announcement Announcement
  • Sticky Sticky
  • Global announcement Global announcement
Current date/time is Wed Jan 23, 2019 4:27 am