The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    What happened to the SP-8?

    Share

    Tom

    Posts : 166
    Join date : 2011-04-04

    What happened to the SP-8?

    Post by Tom on Tue Jul 17, 2012 11:20 am

    I recommended it to a friend. Went to the website and it's gone?
    Only SP-6 and SP-9's now?
    Will the 8 be back?
    It's a great little preamp!

    Smile Tom

    tubes4hifi
    Admin

    Posts : 1261
    Join date : 2008-11-30

    Re: What happened to the SP-8?

    Post by tubes4hifi on Fri Jul 20, 2012 5:09 pm

    I ran out of SP8 boards, it was my most popular preamp for about 5 years.
    But I've got way too many other choices.
    The exact same circuit is now on the SP10 without phono, add the PH6 and you'll have the exact same combo as an SP8.

    Tom

    Posts : 166
    Join date : 2011-04-04

    Re: What happened to the SP-8?

    Post by Tom on Mon Jul 23, 2012 8:18 am

    Ah, thanks Roy!

    Question, do the PH-6 and SP-10 share a powersupply or is one needed for each?
    And, if two supplies, can they share a torroid?
    Obviously they did on the SP-8 and that's why I ask.




    tubes4hifi
    Admin

    Posts : 1261
    Join date : 2008-11-30

    Re: What happened to the SP-8?

    Post by tubes4hifi on Mon Jul 23, 2012 10:10 am

    yes, they share a common power supply and a common toroid transformer

    Tom

    Posts : 166
    Join date : 2011-04-04

    Re: What happened to the SP-8?

    Post by Tom on Mon Jul 23, 2012 12:21 pm

    Excellent! Ya know,
    this may be the last useful site on the interwebs.... Razz
    Thanks again,
    Tom

    Sponsored content

    Re: What happened to the SP-8?

    Post by Sponsored content Today at 1:25 am


      Current date/time is Sun Sep 25, 2016 1:25 am