The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    Anyone installed standard MK III boards into MK IV amps? Could I see pictures of your work?

    Share

    howlin' hoosier

    Posts : 29
    Join date : 2012-04-30

    Anyone installed standard MK III boards into MK IV amps? Could I see pictures of your work?

    Post by howlin' hoosier on Sun Jan 19, 2014 6:44 pm

    Been awhile since I've checked in - I bought some standard MK III boards for my MK IV amps awhile back and finally got around to firing up the soldering iron to put the board kits together. Has anyone installed the MK III boards into their MK IV amps, and if you have, could you post some big ol' pictures of your finished work? I could really use big, clear snaps of your finished boards, as well as under the hood to see how you ran the wiring. I haven't done any repair work in ages, and I'd like some photos to help me ensure I've run wiring to the correct locations as I go. Any help (or suggestions about gremlins you've run into and what you did to solve them) would be greatly appreciated - thanks in advance!

    Mike

    DynakitParts
    Admin

    Posts : 183
    Join date : 2008-11-30

    MK III boards for MK IV amps

    Post by DynakitParts on Mon Jan 20, 2014 9:44 pm

    Hi Mike,
    I see no one replied to your post. Not exactly the answer you were looking for...But a question:

    Why would you install MK III boards in your MK IV amps? This circuit design is designed for either 6550 or KT88 tubes and not EL34 tubes. Board size is different also.

    I imagine you could get these to work but is it worth all the effort?

    Why not just buy the right boards and save these for a future MK III build.

    Just my 2 cents....Trust I did not offend.

    Kevin @ Dynakit



      Current date/time is Sun Dec 11, 2016 1:59 am