The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    no power from TDR board

    Share

    oldvstar

    Posts : 14
    Join date : 2014-01-02

    no power from TDR board

    Post by oldvstar on Thu Jan 30, 2014 12:15 am

    I don't like my first post on this forum to be a "Help" post but here it is; I just finished building a VTA ST70 including a TDR, and the first thing I did was test the TDR board. The red LED turns on when I turn on the amp and after ~17 seconds it goes out and the green LED turns on. Looks good so far, but when I check there is no voltage on pins 4 & 6 on V1. When I did this check again I noticed that even though the green LED turned on I did not hear a click from the relay. I double checked the component and wiring installation and it seems ok but the relay is not activating. What should I check to fix this?
    Nothing like having a new amp and I can't play any music.
    Thanks.

    Terry

    Bob Latino
    Admin

    Posts : 2415
    Join date : 2008-11-26
    Location : Massachusetts

    Re: no power from TDR board

    Post by Bob Latino on Thu Jan 30, 2014 10:06 am

    Hi Terry,

    There should be an audible click when the relay turns on ..

    Unsolder enough wires to the TDR board until you can get at the BOTTOM of the board. Double check to see if all 6 connections of the board to the relay are soldered. Resolder any connections that are unsoldered OR maybe look like they are partially soldered.

    Bob

    oldvstar

    Posts : 14
    Join date : 2014-01-02

    works

    Post by oldvstar on Thu Jan 30, 2014 1:45 pm

    Thanks Bob, don't know how I missed it but one pin was not soldered. I now have the kit up and running, everything else seems to work perfectly.
    Terry

    Bob Latino
    Admin

    Posts : 2415
    Join date : 2008-11-26
    Location : Massachusetts

    Re: no power from TDR board

    Post by Bob Latino on Thu Jan 30, 2014 3:57 pm

    Hi Terry,

     Glad to hear that you are up and running .. Don't feel bad. I have also forgotten to solder a connection now and then ...

    Bob

    Sponsored content

    Re: no power from TDR board

    Post by Sponsored content Today at 2:00 am


      Current date/time is Sun Dec 11, 2016 2:00 am