The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    VTA ST 70 odor

    Share

    jim151

    Posts : 7
    Join date : 2009-12-20

    VTA ST 70 odor

    Post by jim151 on Mon Feb 22, 2010 10:36 am

    My new ST 70 has a odor I think from the Russian caps ? Amp working fine.

    Jim G

    Bob Latino
    Admin

    Posts : 2411
    Join date : 2008-11-26
    Location : Massachusetts

    Re: VTA ST 70 odor

    Post by Bob Latino on Mon Feb 22, 2010 10:49 am

    jim151 wrote:My new ST 70 has a odor I think from the Russian caps ? Amp working fine.

    Jim G

    Hi Jim.

    Every new ST-70 or ST-120 amp (about 75 wired amps) that I have started in the past 5 years up has had an "odor" of some sort when started up and run for the first few hours. After 10 - 50 hours the odor diminishes. It could be the paint on the transformers or the effect of current going through the resistors or capacitors .. It is almost like that new car smell that goes away in time ... Nothing to worry about ..

    Bob

    jim151

    Posts : 7
    Join date : 2009-12-20

    Re: VTA ST 70 odor

    Post by jim151 on Mon Feb 22, 2010 10:59 am

    OK thanks Bob

    Jim

    thevic24

    Posts : 29
    Join date : 2010-01-31

    Re: VTA ST 70 odor

    Post by thevic24 on Mon Feb 22, 2010 11:30 am

    My ST120 did the same thing. Its a combo of new componets,
    paint.

    It will lessen as the amp breaks in.


    Enjoy

    -Vic

    1MOR

    Posts : 19
    Join date : 2010-02-04

    Re: VTA ST 70 odor

    Post by 1MOR on Tue Feb 23, 2010 8:24 pm

    I had the same experience when I fired my ST-70 for the first time over the weekend. Wonderful odor. The smell is gone now and I am experiencing some degree of separation and loss. The great sounds are assisting in my recovery process. lol!

    crxman

    Posts : 4
    Join date : 2011-01-04

    Odor!

    Post by crxman on Tue Jan 04, 2011 2:44 pm

    I have had my new ST-120 that Bob sent me just after Christmas. The odor is not unpleasant and a few of my friends actually enjoyed the smell of newness. BTW... the amp sounds incredible. I am presently using a PAT5 stock preamp but have received the kit for the SP6 that looks suprisingly like an SP8 with three boards and no mute control.... Trying to build up the courage to lay it all out and start stuffing the PCB's.

    Sponsored content

    Re: VTA ST 70 odor

    Post by Sponsored content Today at 8:07 am


      Current date/time is Tue Dec 06, 2016 8:07 am