The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Tubes4hifi VTA tube amp and preamp kits and all Dynakitparts.com products


    Latino VTA-ST-70

    avatar
    rwferr

    Posts : 16
    Join date : 2009-01-11

    Latino VTA-ST-70 Empty Latino VTA-ST-70

    Post by rwferr on Fri Aug 19, 2016 11:13 am

    My Bob Latino built VTA-ST-70 is now over nine years old.  I have one of the first ones Bob ever built in 2007.  I have used it most days for the last nine years.  In fact I was just playing it.  I have not had a moment's trouble with it in nine years.  Its without a doubt one of the best audio pieces I have ever bought and I have played the crap out of it.  Its the only amp I have ever had in that time and I have listened to a bunch of more expensive ones that did not sound any better and many sounded worse.  I have thought about replacing it just cause you get that itch sometimes but I have absolutely no reason to cause the thing still sounds awesome.   Thanks for a great amp Bob I am a totally satisfied customer.
    Bob Latino
    Bob Latino
    Admin

    Posts : 2792
    Join date : 2008-11-26
    Location : Massachusetts

    Latino VTA-ST-70 Empty Re: Latino VTA-ST-70

    Post by Bob Latino on Fri Aug 19, 2016 4:01 pm

    Hi Richard,

    Thanks for your post .. Now and then I get a question about the long term durability of the VTA amps. I built your amp myself but I have many kit builders from 2007/2008 that are still using their amps without any problems. Sure, you should replace the tubes after a period of time but in general, RARELY do people have problem with the amp itself ..

    Bob
    avatar
    RockyAM

    Posts : 26
    Join date : 2008-12-14

    Latino VTA-ST-70 Empty Re: Latino VTA-ST-70

    Post by RockyAM on Fri Aug 19, 2016 5:40 pm

    I have had my ST-70 built from one of Bob's kits since 2008 ... I play it almost every day for maybe 2 or 3 hours and have never had a problem with the amp itself. I changed out all the tubes about 4 years ago because one output tube would not bias anymore ? I probably should be changing out the second set soon ? RockyAM
    avatar
    hrudu90

    Posts : 28
    Join date : 2011-01-02

    Latino VTA-ST-70 Empty Re: Latino VTA-ST-70

    Post by hrudu90 on Sun Aug 21, 2016 2:00 pm

    Hello, I have an older VTA ST-70 which bought it used.
    It has served me well and sounds fantastic. Never a bit of trouble with the amp ...

    Latino VTA-ST-70 DSC02216_zpszapvl0ux

    Sponsored content

    Latino VTA-ST-70 Empty Re: Latino VTA-ST-70

    Post by Sponsored content


      Current date/time is Sun Aug 18, 2019 3:57 am