The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    Introductory Hello & My M125 Build

    Share

    costerdock

    Posts : 35
    Join date : 2011-07-27

    Re: Introductory Hello & My M125 Build

    Post by costerdock on Thu Sep 28, 2017 11:48 am

    I have each of my amps plugged into a HumX device - absolutely no hum at any level - completely black - you wouldn't think the amps were even turned on.

    Congrats on the M125s - I absolutely love mine - they have been running strong over I think 6 years.
    avatar
    Denizen

    Posts : 24
    Join date : 2017-08-15
    Location : Berlin, Germany

    Re: Introductory Hello & My M125 Build

    Post by Denizen on Thu Sep 28, 2017 12:18 pm

    costerdock wrote:I have each of my amps plugged into a HumX device - absolutely no hum at any level - completely black - you wouldn't think the amps were even turned on.

    Congrats on the M125s - I absolutely love mine - they have been running strong over I think 6 years.

    I'm always looking to improve everything soin have beena looking at Airlink et al. I'll definitely check out HumX now too.

    Edit; just had a quick look and the HumX doesn't look at all lik a good deal. I feel pretty sure that it's simply a noise suppression capacitor which would cost you all of a couple of bucks.

      Current date/time is Sat Dec 16, 2017 2:39 pm