The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    My first restore

    Share
    avatar
    ttownscott

    Posts : 25
    Join date : 2018-07-31
    Age : 54
    Location : Tacoma, WA

    My first restore

    Post by ttownscott on Sun Aug 12, 2018 2:47 am

    Like many I had a Dynaco ST-70 in my youth. I was given one in college and used it all throughout and then left it with one of my roommates when I graduated.

    Now I'm a bit nostalgic and decided I wanted to fit one into my system. Doing a search and wow. These guys are expensive! Looks like free was out of the question, but I found one without tubes for $330 and I actually have a matched set of EL34's for a different amp anyway.

    So after research, I realize there are some first things first, such as replacing the selenium rectifier and upgrading the cap. I ordered the bias kit and a quad cap from Dynakitparts and will check the transformers. Then I plan on striping everything off the chassis and cleaning it up and repainting the transformers. I am optimistic based on the other posts I have seen.

    This is not going to be a VTA70 build. I would like to build one of the VTA120 or M-125 sets after this though. I will just use one of the ebay 6GH8A boards to keep it as stock as possible.

    I would like to get a recommendation of what chassis resisters to use if I replace them and where is a good place to buy them. I am also on the fence about weather it is necessary to use new tube sockets or retension and re-use the existing ones.

    With out further adieu. Her is what I am starting with.

    The amp with cover:


    Cover off


    The underside



    Look at those original Dynaco caps!


    My first shipment from Dynakitparts
    avatar
    WLT

    Posts : 31
    Join date : 2013-07-13
    Location : Rochester NY

    Ask over at the "basket"

    Post by WLT on Sun Aug 12, 2018 10:50 am

    Great post and I will respond but not here. Your request for a discussion should be posted in the Basket section not in the photo section of this forum. I have a pair of Dyna MK IIs that I am doing a similar restore to. I will respond accordingly if you repost this request over there. Thanks
    avatar
    ttownscott

    Posts : 25
    Join date : 2018-07-31
    Age : 54
    Location : Tacoma, WA

    Re: My first restore

    Post by ttownscott on Sun Aug 12, 2018 3:02 pm

    Thanks. I'll keep this for progress and re-post over there

    Sponsored content

    Re: My first restore

    Post by Sponsored content


      Current date/time is Thu Oct 18, 2018 2:20 am