The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    Stupid question regarding new KT66 tubes

    Share

    talsmaja

    Posts : 9
    Join date : 2016-11-20

    Stupid question regarding new KT66 tubes

    Post by talsmaja on Mon Sep 17, 2018 11:31 pm

    Hi all, I just got a quad set of matched Gold Lion KT66's for my VTA ST-70. It's been a while since I changed the tubes, can I just pull the old EL34's I have installed and follow the install and bias procedure outlined in Bob's manual that came with the kit (using .45 VDC from the sticky post)? Is there anything else I would need to do? I'm also going to swap the rectifier for a new one. I know, stupid question huh? Thanks!
    avatar
    bluemeanies

    Posts : 260
    Join date : 2015-02-09
    Age : 68
    Location : Folsom Pa.

    Re: Stupid question regarding new KT66 tubes

    Post by bluemeanies on Tue Sep 18, 2018 5:00 am

    NOT A STUPID QUESTION

    Depending how long you have had the tubes or if you just feel the tube sockets need cleaning you should buy some Deoxit cleaner and clean the sockets before installing your KT66 tubes. You can use a small dental brush (I think they sell them in multi packs CHEAP) that fits into the tubes sockets. Spray the brush...NOT THE SOCKET...and proceed to clean each socket hole. Take a brake and let them dry for about 15-30minutes and you will be good to go. I believe the Deoxit has acetone in it and therefore drys relatively fast. (read directions) Then put your new tubes in and turn on the valves.
    WARNING: before you install new tubes and turn on your ST70 make sure your let the sockets dry.
    Don't rush.

    Hope this helped.
    avatar
    Dave_in_Va

    Posts : 244
    Join date : 2013-04-02

    Re: Stupid question regarding new KT66 tubes

    Post by Dave_in_Va on Tue Sep 18, 2018 9:39 am

    I think I'd recommend re-tensioning the sockets. It doesn't take long.

    The only problem I ever had with my ST 70- was losing an EL 34 and a nice NOS Mullard 5AR4. I'm 100% convinced it was a result of me rolling different EL 34's when I first received the amp.

    talsmaja

    Posts : 9
    Join date : 2016-11-20

    Re: Stupid question regarding new KT66 tubes

    Post by talsmaja on Tue Sep 18, 2018 11:05 pm

    Thanks for the tips! And just following the biasing procedure in from Bob's manual with .45 VDC should do the trick right?
    avatar
    bluemeanies

    Posts : 260
    Join date : 2015-02-09
    Age : 68
    Location : Folsom Pa.

    Re: Stupid question regarding new KT66 tubes

    Post by bluemeanies on Wed Sep 19, 2018 4:29 am

    talsmaja wrote:Thanks for the tips! And just following the biasing procedure in from Bob's manual with .45 VDC should do the trick right?

    I am not familiar with with biasing the ST70 but surely if you have the manual and it reads that .45 VDC is the correct setting you are good to go.
    If in doubt email Bob. He responds quickly.
    I have the m125 mono-blocks and my bias setting is .500 with two tubes in each amplifier.

    Jim McShane

    Posts : 208
    Join date : 2011-10-19
    Location : South Suburban Chicago

    Re: Stupid question regarding new KT66 tubes

    Post by Jim McShane on Wed Sep 19, 2018 12:49 pm

    Dave_in_Va wrote:I think I'd recommend re-tensioning the sockets. It doesn't take long.

    The only problem I ever had with my ST 70- was losing an EL 34 and a nice NOS Mullard 5AR4. I'm 100% convinced it was a result of me rolling different EL 34's when I first received the amp.

    I second Dave' post said! Tube sockets require some maintenance, and a tube change is a perfect time to do it. I posted a tube FAQ on Audio Asylum so if you want to learn more about it look here: Tube FAQ

    Item #1 deals with tube to socket contact issues but I hope you can make time to read the whole thing.

    Enjoy those GREAT tubes!

    Sponsored content

    Re: Stupid question regarding new KT66 tubes

    Post by Sponsored content


      Current date/time is Sat Dec 15, 2018 4:15 am