The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    ST70 build, progressive photo's

    Share

    Guest
    Guest

    ST70 build, progressive photo's

    Post by Guest on Sat Feb 15, 2014 3:39 pm

    the beginning of my ST70 assembly

    http://s1029.photobucket.com/user/MontanaWay/slideshow/

    Guest
    Guest

    Re: ST70 build, progressive photo's

    Post by Guest on Sun Feb 16, 2014 8:32 pm

    added one more, bulk of the main wiring is done.

    http://s1029.photobucket.com/user/MontanaWay/slideshow/

    Guest
    Guest

    Re: ST70 build, progressive photo's

    Post by Guest on Mon Feb 17, 2014 5:01 pm

    well, fired up the beasty today, everything seems good, ran a sine wave from my signal generator through it, works great, no hum that I can hear, on the scope it looks pretty darn clean too!
    I'll et it sit overnight before connecting the phono.  Very Happy 

    Guest
    Guest

    Re: ST70 build, progressive photo's

    Post by Guest on Wed Feb 26, 2014 6:47 pm

    WOOOOOW!!!!!!.....this is the first time since I can remember that I have listened to a tube amp, the sound is just amazing! Today I have run up my ST-70 for the first time, and listened to a jazz version of Bach to Dark Side Of The Moon, just an amazing sound! The bass is just amazing, not to mention the higher frequencies as well, clear, crisp, no hum....wow!
    The new Klipsch speakers too are amazing!
    It will remain on my workbench for a few days, running it each day for a couple of hours. I am still waiting on the new front face plate as well as the top plate.
    Can't wait to get the SP9 all built and put into the circuit!
    I also have a matched set of Gold Lion KT66's coming, really can't wait to listen to those.

    http://s1029.photobucket.com/user/MontanaWay/slideshow/

    Guest
    Guest

    Re: ST70 build, progressive photo's

    Post by Guest on Fri Feb 28, 2014 10:34 pm

    well I finally got my plates today, I think they turned out really good!
    Still waiting for the small bias 4mm sockets. That ungainly volume control is of course temporary, as you've probably noticed, I have done away with the attenuator option, since I will be plugging my SP9 into the amp, but until it is finished, the temp volume control will stay.

    http://s1029.photobucket.com/user/MontanaWay/slideshow/

    Guest
    Guest

    Re: ST70 build, progressive photo's

    Post by Guest on Sun Mar 09, 2014 4:40 pm

    well I got back from Mardis Gras in New Orleans yesterday, so today, I installed the Gold Lion KT66 matched tubes.
    Quite a difference in the sound, more bass for sure, I like them, so for now, will keep them in the ST70!
    The custom chassis for my SP9 preamp is arriving this week, so will get started on that. For now, the ST70 is residing in its final place with the temp volume control hanging off it. Once the preamp is all done, the temp volume will be removed.
    System sound awesome!, those Klipsch speakers sure do it justice!

    Guest
    Guest

    Re: ST70 build, progressive photo's

    Post by Guest on Thu Mar 13, 2014 11:54 pm

    here is a photo I just added of my ST70 temp setup with the KT66's in our lounge, once the custom SP9 is finished, the temp volume control will be removed and the cabling cleaned up.

    http://s1029.photobucket.com/user/MontanaWay/slideshow/

    Sponsored content

    Re: ST70 build, progressive photo's

    Post by Sponsored content Today at 9:03 pm


      Current date/time is Fri Dec 09, 2016 9:03 pm