The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    First attempt at restoring old Dyna tube amps

    Share

    j beede

    Posts : 316
    Join date : 2011-02-07
    Location : California

    First attempt at restoring old Dyna tube amps

    Post by j beede on Sun Mar 13, 2011 10:28 pm

    I bought a pair of Mark IIIs a little over a month ago... I knew I was in trouble when I got to the guy's house and he took me out to a shed where he kept the "old hifi stuff". I tried to negotiate a better price but this was hard to do as he got three more calls from prospective buyers while we stood out in the dark--me trying to see what I was buying with a borrowed flashlight with weak batteries. Long story short... I got the amps home--they were ugly and blew fuses. Then I discovered this forum and Bob's generous supply of schematics and pictorials. I went ahead and stripped the amps down. I washed, polished, sanded, painted, wire brushed screw heads, bypassed quad cap sections, built under-chassis cap boards, inserted diodes, retubed, replaced resistors and as of last Friday night installed the completed pair in the downstairs listening room. How do they sound? Good. Very good.


    j beede

    Posts : 316
    Join date : 2011-02-07
    Location : California

    Re: First attempt at restoring old Dyna tube amps

    Post by j beede on Sun Mar 20, 2011 10:08 pm

    ...and the PAS-2 is done now too.


    JunkyJan

    Posts : 100
    Join date : 2008-12-09
    Location : BC, Canada

    Looks VERY good!

    Post by JunkyJan on Wed Jun 29, 2011 5:59 pm

    Almost new, AAMOF! Great job, and good to see a pair of Mark IIIs being rescued.

    -- JunkyJan

    Sponsored content

    Re: First attempt at restoring old Dyna tube amps

    Post by Sponsored content Today at 1:18 am


      Current date/time is Tue Sep 27, 2016 1:18 am