The Dynaco Tube Audio Forum

Would you like to react to this message? Create an account in a few clicks or log in to continue.
The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Tubes4hifi VTA tube amp and preamp kits and all Dynakitparts.com products


    My Stereo 70

    avatar
    Lou deGonzague

    Posts : 2
    Join date : 2019-01-12

    My Stereo 70 Empty My Stereo 70

    Post by Lou deGonzague on Thu Feb 28, 2019 6:01 pm

    Here is my 70, very nice condition.  New caps and driver boardMy Stereo 70 00411
    WLT
    WLT

    Posts : 127
    Join date : 2013-07-13
    Location : Rochester NY

    My Stereo 70 Empty Re: My Stereo 70

    Post by WLT on Fri Mar 08, 2019 9:58 am

    It looks great. The replacement board looks like the original circuit with the 7199. Correct? Where did you get the board? and then where did you get the metal film resisters and caps from? Or was it all sold as a package?

    It looks very clean so I assume you cleaned and polished it. Any special products used? Or is is new?

    The all important question. How does it sound?

    I am working on my ST70 which is in about the same physical condition as yours but with the original board. Replacing all out of spec resistors and the feedback caps.
    avatar
    Lou deGonzague

    Posts : 2
    Join date : 2019-01-12

    My Stereo 70 Empty Re: My Stereo 70

    Post by Lou deGonzague on Fri Mar 08, 2019 12:41 pm

    Don't remember where I got the board, off eBay I guess it was a while ago. I had the caps and got the resistor at a local supply house. I think I used Top Brite metal polish, the amp was in very nice condition when I got it. The filter cap came from AES. The traces on the original board are easy to lift off so I went with a nice new fiberglass one.
    WLT
    WLT

    Posts : 127
    Join date : 2013-07-13
    Location : Rochester NY

    My Stereo 70 Empty Re: My Stereo 70

    Post by WLT on Wed Mar 13, 2019 12:30 pm

    Your amp looked so nice I had to finish mine. The last of the capacitors came in so I finished it yesterday. Polished it and just set the bias. I thought I would post a photo of it here. Both amps look very nice and the biggest difference is your new board vs. my original board. Mine has all new caps through out, 14 resistors replaced to bring them within 2% tolerance of published schematic. Even better tolerance channel to channel. 6GH8s with adapters. Sounds just fine.

    My Stereo 70 Img_2010
    pichacker
    pichacker

    Posts : 103
    Join date : 2016-08-01
    Age : 56
    Location : Near to London - UK

    My Stereo 70 Empty Re: My Stereo 70

    Post by pichacker on Thu Mar 14, 2019 4:01 am

    Is that just the photo or is the Getter a little soft on the rear right tube? Nice and clean.
    PeterCapo
    PeterCapo

    Posts : 927
    Join date : 2008-12-05

    My Stereo 70 Empty Re: My Stereo 70

    Post by PeterCapo on Thu Mar 21, 2019 10:31 am

    Nice to see these classics get the care and respect they deserve!

    Sponsored content

    My Stereo 70 Empty Re: My Stereo 70

    Post by Sponsored content


      Current date/time is Mon Oct 26, 2020 6:15 pm