The Dynaco Tube Audio Forum

Would you like to react to this message? Create an account in a few clicks or log in to continue.
The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Tubes4hifi VTA tube amp and preamp kits and all Dynakitparts.com products


3 posters

    Dynaco SCA-35 hum/ground issue

    Vimmy
    Vimmy


    Posts : 1
    Join date : 2021-11-04
    Location : Sweden

    Dynaco SCA-35 hum/ground issue Empty Dynaco SCA-35 hum/ground issue

    Post by Vimmy Thu Nov 04, 2021 2:44 pm

    Hi everyone!

    I'm new to the tube-world (and to this forum). I recently aquired a Dynaco SCA-35 that has a hum/ground issue. It worked fine at the sellers place, although he only demostrated the unit playing Radio and CD - but assured the Phono-stage was just as flawless.

    At home I hook up my turntable and immediately there is a hum/ground issue present in both speakers. It increases past 12 'o clock on the volume knob. And goes way by unplugging the turntable (both power and rca-cables). No hum/ground issue present when on Tape/Radio/Spare. I begin with cleaning the unit from dust and Deoxit all pots & tube sockets. That didn't help (but well overdue).

    So it's narrowed down to the Phono-stage. So how should I proceed? It has the original tubes from when it was assembled. Should I begin with two new sets of 12AX7 tubes? Or could this be a "deeper" problem? Longterm I'm planning on upgrading this unit with available mods. But for now I just need this hum/ground issue to disappear. Any thoughts? Smile

    Edit: I forgot to clarify that the hum is present at Phono with nothing connected as well.
    peterh
    peterh


    Posts : 1599
    Join date : 2012-12-25
    Location : gothenburg, sweden

    Dynaco SCA-35 hum/ground issue Empty Re: Dynaco SCA-35 hum/ground issue

    Post by peterh Thu Nov 04, 2021 5:00 pm

    Vimmy wrote:Hi everyone!

    I'm new to the tube-world (and to this forum). I recently aquired a Dynaco SCA-35 that has a hum/ground issue. It worked fine at the sellers place, although he only demostrated the unit playing Radio and CD - but assured the Phono-stage was just as flawless.

    At home I hook up my turntable and immediately there is a hum/ground issue present in both speakers. It increases past 12 'o clock on the volume knob. And goes way by unplugging the turntable (both power and rca-cables). No hum/ground issue present when on Tape/Radio/Spare. I begin with cleaning the unit from dust and Deoxit all pots & tube sockets. That didn't help (but well overdue).

    So it's narrowed down to the Phono-stage. So how should I proceed? It has the original tubes from when it was assembled. Should I begin with two new sets of 12AX7 tubes? Or could this be a "deeper" problem? Longterm I'm planning on upgrading this unit with available mods. But for now I just need this hum/ground issue to disappear. Any thoughts? Smile

    Edit: I forgot to clarify that the hum is present at Phono with nothing connected as well.

    Best way is to start with a couple of grounding plugs.  Or if missing connect one
    cable with rca connectors on each end between phono left and phono right.
    If hum is still there you have isolated to the riaa stage.

    If so, get replacemet ECC83 tubes. The best you can get is E83CC from eurotubes.com,
    they are not that expensive , or ECC83S from the same place.
    Reason for this is that the riaa tubes are heated with AC and leakage
    between filament and catode is common on old tubes.

    In the meantime you could exersize the "hum pots" at the backside of the amp.
    They will side by side try to eleminate must of the 60hz hum that is caused
    by the AC filements. Find the point where the hum is less.

    /PS
    the tubes mentioned may be obtained at tubular-well.se
    i have an affiliation, i hope that is ok since both vinnie and i live an
    a distant remote where tube distributors are scarce
    /DS


    Last edited by peterh on Thu Nov 04, 2021 5:02 pm; edited 1 time in total (Reason for editing : Tube tips)

    Vimmy likes this post

    boscode
    boscode


    Posts : 5
    Join date : 2015-06-11

    Dynaco SCA-35 hum/ground issue Empty Re: Dynaco SCA-35 hum/ground issue

    Post by boscode Fri Nov 12, 2021 2:33 pm

    Also, try reversing the AC plug for the turntable, if possible. Sometimes this removes hum. (Unless of course, you still had hum with TT AC unplugged.)

    Sponsored content


    Dynaco SCA-35 hum/ground issue Empty Re: Dynaco SCA-35 hum/ground issue

    Post by Sponsored content


      Current date/time is Mon Dec 06, 2021 4:58 pm