The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all products and all products

    My ST120...



    Posts : 29
    Join date : 2010-01-31

    My ST120...

    Post by thevic24 on Sat Apr 14, 2012 7:20 pm

    Well IIRC...(I am as of Feb 19, my ST120 turned 2 years old.

    She is still making beautiful sounds and amazingly enough...I am still using the same 6550's. I actually just got them back from being tested by Jim McShane and they still have over 85% life left in them. (He tested them at full operating voltages)

    I think they have around 2.5-3k hours on them.

    Any who, again a BIG thanks to Bob for building me a great amp!!

    Lately, I have been using it more and more. I am watching Moonshiners on tv and using her for the sound....I think my Carver is getting jealous!!

    Hey Bob, I like the looks of the 500w monoblock you are thinking about. 16 power tubes?? May need extra air

    Thanks again!!


    Bob Latino

    Posts : 2384
    Join date : 2008-11-26
    Location : Massachusetts

    Re: My ST120...

    Post by Bob Latino on Sat Apr 14, 2012 9:06 pm

    Hi Vic,

    Glad to hear that your amp is running well after 2+ years ....

    Whaddya mean 16 output tubes on those 500 watt monoblocks ? Your gonna need another monoblock for the other channel ! Make that 32 output tubes and two built in heaters that you really don't need living in FL - lololo


      Current date/time is Fri Oct 28, 2016 5:35 pm