The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Tubes4hifi VTA tube amp and preamp kits and all Dynakitparts.com products


    AB for M125?

    deepee99
    deepee99

    Posts : 2231
    Join date : 2012-05-23
    Location : Wallace, Idaho

    AB for M125? - Page 2 Empty Re: AB for M125?

    Post by deepee99 on Fri Jul 26, 2019 11:45 am

    tubes4hifi wrote:I've never had any trouble with steady bias on EL34 tubes, but many many times have had trouble keeping steady bias with KT88 tubes.
    Make sure your bias grid resistors are 100K or less.   If you ever run KT120 or KT150 those resistors need to be 51K.  (R29-32 on any VTA board)
    Roy, IME the bias pots on VTA's circuits are most sensitive on the ST-70. Plenty of slop factor on the M-125s, but going from .35 to .40 in a ST-70 is about a jeweler's screwdriver's blade width.
    LeGrace
    LeGrace

    Posts : 320
    Join date : 2016-08-07
    Location : Ontario, Canada

    AB for M125? - Page 2 Empty Re: AB for M125?

    Post by LeGrace on Mon Jul 29, 2019 6:25 pm

    Not an easy upgrade, really struggling on the first one. Installing all the wires onto the bottom of the AB board turned out to be a major mistake. Instructions say this is the neater option, more like the impossible option. Had to take a break got so frustrated. Will go at it again in the morning.
    LeGrace
    LeGrace

    Posts : 320
    Join date : 2016-08-07
    Location : Ontario, Canada

    AB for M125? - Page 2 Empty Re: AB for M125?

    Post by LeGrace on Wed Jul 31, 2019 8:31 pm

    Way less tricky installing the board first then attaching wires to top side. Still working on some issues but looking forward to benefits of this mod.
    LeGrace
    LeGrace

    Posts : 320
    Join date : 2016-08-07
    Location : Ontario, Canada

    AB for M125? - Page 2 Empty Re: AB for M125?

    Post by LeGrace on Sun Aug 18, 2019 2:43 pm

    Both amps are converted and operating well. Definitely not missing those manual trim pots! Once I switched to attaching wires to the top of the board the installation process became a lot easier.

    I read about some of the early issues with these boards but the new Ver 2 clearly addresses those.

    Interesting what you find when you open up your amps after a couple years. In my case a noticeably domed cap and a couple burnt resistors. Besides the upgrade it was definitely time for a tune up!
    LeGrace
    LeGrace

    Posts : 320
    Join date : 2016-08-07
    Location : Ontario, Canada

    AB for M125? - Page 2 Empty Re: AB for M125?

    Post by LeGrace on Tue Sep 03, 2019 2:49 pm

    Well with a couple weeks under the belt I can state that I am really liking these AB boards. The daily tedium of bias checking and adjustment is quickly fading into a bad memory. Unlike BAB (Before AB) the bias is always dead on now, and I mean dead on. Each day reading across tubes is exactly the same as previous day, within 0.001 V, incredible. Installing them was well worth the effort. There is an adjacent benefit as well in more consistent sound quality.

    Sponsored content

    AB for M125? - Page 2 Empty Re: AB for M125?

    Post by Sponsored content


      Current date/time is Tue Sep 17, 2019 3:24 am