The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    Dynaco MarkVI ?

    Share

    terry37932

    Posts : 22
    Join date : 2011-05-18
    Location : Knoxville

    Dynaco MarkVI ?

    Post by terry37932 on Tue Oct 11, 2011 9:33 am

    Dynaco Mark VI? Rare?

    ebay: 180736673273, I just never knew there was that particular model. it looks really nice anyway.

    Bob Latino
    Admin

    Posts : 2378
    Join date : 2008-11-26
    Location : Massachusetts

    Re: Dynaco MarkVI ?

    Post by Bob Latino on Tue Oct 11, 2011 11:27 am

    The Dynaco Mark VI came out in 1976. For its time it wasn't a bad amp. It lacked DC power storage and also used 8417 output tubes which (according to Dynaco) there is (was) no substitute. I'm sure the circuit could probably be reworked so that the amp could use KT88 output tubes. In case anyone wants a more in depth look at the Mark VI, the assembly manual and a description of the amp is at the link below ..

    Dynaco Mark VI Assembly manual

    Bob

    Sal

    Posts : 223
    Join date : 2009-02-05
    Location : Central New Jersey Dynaco-ST70.com

    Re: Dynaco MarkVI ?

    Post by Sal on Tue Oct 11, 2011 1:41 pm

    I was lucky enough to grab pair of Mark 6's this past February missing the 8417's, I have since purchase 10 NOS 8417's but have not tried the amps yet, actually the seller had 6550's in them so I was able to make sure they worked before I purchased them. They have not been modified and are all original.

    The 8417's are $$$ and not stable tubes from what I read. Only 2000 were sold in mid 1970's before Dynaco went defunct.

    Sal

    Sponsored content

    Re: Dynaco MarkVI ?

    Post by Sponsored content Today at 7:43 pm


      Current date/time is Thu Sep 29, 2016 7:43 pm