The Dynaco Tube Audio Forum

Would you like to react to this message? Create an account in a few clicks or log in to continue.
The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Tubes4hifi VTA tube amp and preamp kits and all Dynakitparts.com products


    Speakers Pop on turnoff

    eminence1963
    eminence1963

    Posts : 11
    Join date : 2019-06-10

    Speakers Pop on turnoff Empty Speakers Pop on turnoff

    Post by eminence1963 on Thu Feb 13, 2020 7:30 pm

    My Speakers are popping when I turn the power amps off. Suggestions on what I should do? I have the ST120 and my PL Prologue 5 plugged into a Panamax MR5100. Not a good idea to plug these into the panamax? I did not have this problem with my other setup prior to me adding in the ST120 and SP14, which I just got this month.
    corndog71
    corndog71

    Posts : 733
    Join date : 2013-03-19
    Location : It can get windy here

    Speakers Pop on turnoff Empty Re: Speakers Pop on turnoff

    Post by corndog71 on Thu Feb 13, 2020 9:51 pm

    Are you shutting the amp off first?
    eminence1963
    eminence1963

    Posts : 11
    Join date : 2019-06-10

    Speakers Pop on turnoff Empty Re: Speakers Pop on turnoff

    Post by eminence1963 on Thu Feb 13, 2020 10:37 pm

    corndog71 wrote:Are you shutting the amp off first?
    Yes
    10-E-C
    10-E-C

    Posts : 265
    Join date : 2014-02-12
    Age : 66
    Location : upper east tn

    Speakers Pop on turnoff Empty Re: Speakers Pop on turnoff

    Post by 10-E-C on Fri Feb 14, 2020 6:33 am

    eminence1963 wrote:
    corndog71 wrote:Are you shutting the amp off first?
    Yes

    After you turn your amp off first, are you waiting about 45 seconds for the caps to discharge before turning off your pre amp and source?
    Brap
    Brap

    Posts : 123
    Join date : 2013-11-28
    Age : 64
    Location : Lisle, Illinois

    Speakers Pop on turnoff Empty Re: Speakers Pop on turnoff

    Post by Brap on Fri Feb 14, 2020 10:58 am

    FWIW, in my system (Parasound pre-amp, VTA ST-70) is to mute the preamp first then power down the ST-70. Issue solved.
    eminence1963
    eminence1963

    Posts : 11
    Join date : 2019-06-10

    Speakers Pop on turnoff Empty Re: Speakers Pop on turnoff

    Post by eminence1963 on Fri Feb 14, 2020 11:44 am

    10-E-C wrote:
    eminence1963 wrote:
    corndog71 wrote:Are you shutting the amp off first?
    Yes

    After you turn your amp off first, are you waiting about 45 seconds for the caps to discharge before turning off your pre amp and source?
    Not even turning the preamp off. Just the amps, and pop.
    eminence1963
    eminence1963

    Posts : 11
    Join date : 2019-06-10

    Speakers Pop on turnoff Empty Re: Speakers Pop on turnoff

    Post by eminence1963 on Fri Feb 14, 2020 11:48 am

    Its one of the 4 powered subs that's causing the issue. Now its on to process of elimination on which one.

    Sponsored content

    Speakers Pop on turnoff Empty Re: Speakers Pop on turnoff

    Post by Sponsored content


      Current date/time is Mon Jul 06, 2020 5:15 pm