The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Dynaco VTA tube amp kits, all Tubes4hifi.com products and all Dynakitparts.com products


    dynaco sca-35 phono amplification on right speeker doesn't work

    Share

    gpdavid

    Posts : 2
    Join date : 2011-01-28
    Age : 25
    Location : netherlands

    dynaco sca-35 phono amplification on right speeker doesn't work

    Post by gpdavid on Fri Jan 28, 2011 8:05 am

    hej guys, i just bought a dynaco sca-35 to get into tube amps. the spare in works great and i can listen to music from my computer. but the right speeker only makes a buzzing noise when using the phone in. what could the problem be? the tubes seem to all be lighting up..
    cheers guys!

    dynacophil

    Posts : 33
    Join date : 2010-10-26
    Age : 59
    Location : Berlin/Germany

    Re: dynaco sca-35 phono amplification on right speeker doesn't work

    Post by dynacophil on Fri Jan 28, 2011 12:23 pm

    Hi David
    Phone in? You mean phono in? what do you feed the phono in with? Is the source you feed into phono (a record player) unsuspect? If it's proven no failure of the source...
    At first I'd check the tube sockets and pins for good contact and then resolder all joints from input to the end of phono stage...to my oldtimer experience solderjoints are 90% of the failures Smile if this won't help... somebody will chime in...


    Helge


    Last edited by dynacophil on Fri Jan 28, 2011 2:00 pm; edited 1 time in total

    gpdavid

    Posts : 2
    Join date : 2011-01-28
    Age : 25
    Location : netherlands

    Re: dynaco sca-35 phono amplification on right speeker doesn't work

    Post by gpdavid on Fri Jan 28, 2011 1:59 pm

    jup i mean phono in Smile it's indeed a record player which i tested on another amp and it works fine there.. if i decide not to fix the problem, could that damage the working components?

    dynacophil

    Posts : 33
    Join date : 2010-10-26
    Age : 59
    Location : Berlin/Germany

    Re: dynaco sca-35 phono amplification on right speeker doesn't work

    Post by dynacophil on Fri Jan 28, 2011 2:48 pm

    as long you don't know what the problem is u can't tell ... so - diagnosis is necessary.

    Bob Latino
    Admin

    Posts : 2374
    Join date : 2008-11-26
    Location : Massachusetts

    Re: dynaco sca-35 phono amplification on right speeker doesn't work

    Post by Bob Latino on Fri Jan 28, 2011 5:18 pm

    Hi,

    Try the obvious first by swapping the two 12AX7 tubes on the PC-11 phono board which is under the selector switch. If the noise moves to the other channel just replace the bad tube. I have a feeling though that a tube is not your problem. It's probably some component on the PC-11 phono board.

    It could alo be a bad connection on one of the wires that connects to this board. You can try resoldering all the wires that lead into the eyelets on that PC-11 phono board. Also check the 6 wires that connect on the BOTTOM of the phono board and resolder them too.

    Bob

    ejc

    Posts : 25
    Join date : 2010-10-16
    Age : 65
    Location : Connecticut

    Re: dynaco sca-35 phono amplification on right speeker doesn't work

    Post by ejc on Fri Jan 28, 2011 7:10 pm

    Bob Latino wrote:Hi,

    Try the obvious first by swapping the two 12AX7 tubes on the PC-11 phono board which is under the selector switch. If the noise moves to the other channel just replace the bad tube. I have a feeling though that a tube is not your problem. It's probably some component on the PC-11 phono board.

    It could alo be a bad connection on one of the wires that connects to this board. You can try resoldering all the wires that lead into the eyelets on that PC-11 phono board. Also check the 6 wires that connect on the BOTTOM of the phono board and resolder them too.

    Bob

    Along those lines, Dynaco used solid core wire back then. My experience with my PAT-4 found these wires to be fragile and several just fell into my hand when touched.

    Also check the selector switch. I found a broken wafwr on mine causing one of the inputs to drop out on 1 channel

    Sponsored content

    Re: dynaco sca-35 phono amplification on right speeker doesn't work

    Post by Sponsored content Today at 8:15 pm


      Current date/time is Sat Sep 24, 2016 8:15 pm