The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Tubes4hifi VTA tube amp and preamp kits and all Dynakitparts.com products


Basket

TopicsRepliesAuthorViewsLast Posts
No new posts   Electric Zap sound and shut off on my VTA ST-70 2James_Weir231View latest post on Sat May 02, 2020 9:17 pm
by James_Weir
No new posts   A week of listening to my VTA 70 and im hooked! 6Midwestside468View latest post on Fri May 01, 2020 10:50 am
by Midwestside
No new posts   PSVANE KT88-T MARK ii 1rodulfo23398View latest post on Fri May 01, 2020 4:38 am
by Halvis
No new posts   Output Tube Arcing? 3medphys266View latest post on Tue Apr 28, 2020 1:57 pm
by Bob Latino
No new posts   NOS Mullard 12au7 Lights up bright inside tube on start up but amp seems to play fine. 5Midwestside292View latest post on Mon Apr 27, 2020 10:37 pm
by Midwestside
No new posts   Hi/Lo phono inputs on old int. tube amp (Harmon Kardon) 4Dave_in_Va192View latest post on Sun Apr 26, 2020 6:38 pm
by Dave_in_Va
No new posts   Mark III Output Transformers 0OldFrisco361View latest post on Sat Apr 25, 2020 6:50 pm
by OldFrisco
No new posts   Random red plate on a stock Dynaco ST-70 amp 9boeingpilot535View latest post on Sat Apr 25, 2020 11:36 am
by PeterCapo
No new posts   2x original Dynaco ST-70's with VTA board with continued issues after service 20Sigjunk1707View latest post on Fri Apr 24, 2020 6:39 pm
by fenderbender
No new posts   ST-120 Amp Repair? 0music307View latest post on Thu Apr 23, 2020 12:32 pm
by music
No new posts   Question about el34 and / or tube filaments 2Midwestside227View latest post on Tue Apr 21, 2020 9:07 pm
by Midwestside
No new posts   Finally got my VTA ST 70 rolling 4Midwestside299View latest post on Mon Apr 20, 2020 8:32 pm
by wildiowa
No new posts   RESOLVED - original Dyna / VTA ST-70- One Output Tubes Doesn't Light 2knotscott212View latest post on Thu Apr 16, 2020 3:29 pm
by knotscott
No new posts   Gold Lion KT-88 Issues? 4music505View latest post on Wed Apr 15, 2020 7:06 pm
by wildiowa
No new posts   Loving the AB's 5LeGrace486View latest post on Wed Apr 15, 2020 6:13 am
by Hops
No new posts   Question about Open loop gain for VTA-70 8peterh588View latest post on Sun Apr 12, 2020 3:46 pm
by peterh
No new posts   RESOLVED: Original Dynaco ST-70 with VTA driver board bias Problem - One Output Tube Glows Cherry Red 12knotscott834View latest post on Sat Apr 11, 2020 6:51 pm
by knotscott
No new posts   Dynaco A 10 Crossover help 3jefe59286View latest post on Wed Apr 08, 2020 4:01 pm
by jefe59
No new posts   PH-14 Phono PCB 1Udo355View latest post on Fri Apr 03, 2020 4:22 pm
by DavidR
No new posts   Fuse in the ST-120? 2music354View latest post on Fri Apr 03, 2020 7:31 am
by Bob Latino
No new posts   Same tube keeps going bad 19MechEngVic696View latest post on Thu Apr 02, 2020 3:22 am
by peterh
No new posts   PAS-3 humming phono 7ViperZ762View latest post on Tue Mar 31, 2020 6:15 pm
by setu
No new posts   Serious Red Plate event 19CletusB1467View latest post on Tue Mar 31, 2020 8:30 am
by CletusB
No new posts   Dynaco PAS built-in buffer 0peterh213View latest post on Mon Mar 30, 2020 10:28 am
by peterh
No new posts   Both MK-III monoblocks started to hum 17ViperZ1223View latest post on Sat Mar 28, 2020 10:26 am
by ViperZ
No new posts   R29 - 32 ST-120 driver board 3Dale Stevens425View latest post on Thu Mar 26, 2020 8:07 pm
by tubes4hifi
No new posts   help needed with Sound Values #957003 board 2Antonn378View latest post on Thu Mar 26, 2020 7:55 pm
by tubes4hifi
No new posts   Upgraded caps and now no sound on St120 7eminence1963454View latest post on Thu Mar 26, 2020 7:52 pm
by Bob Latino
No new posts   Higher bias on one socket 2corndog71245View latest post on Thu Mar 26, 2020 4:06 pm
by corndog71
No new posts   Original Dynaco ST 70 Producing slight hum in left channel  3wazowski357View latest post on Wed Mar 25, 2020 7:00 pm
by wazowski
No new posts   Teflon Wire Stripper 2Mark Korda296View latest post on Wed Mar 25, 2020 2:20 am
by Mark Korda
No new posts   ST 70 Restoration Time Lapse/Condensed Video 5jrubin467View latest post on Tue Mar 24, 2020 11:38 pm
by jrubin
No new posts   SP14 question 2ikir418View latest post on Sun Mar 22, 2020 7:19 pm
by ikir
No new posts   Weird problem with MK-III amplifier 22ViperZ563View latest post on Thu Mar 19, 2020 4:38 pm
by peterh
No new posts   Dynaco PAS-3 rear panel replacement 2ViperZ335View latest post on Thu Mar 19, 2020 3:48 pm
by ViperZ
No new posts   Dynaco PAS-3 volume notch  3ViperZ340View latest post on Thu Mar 19, 2020 3:43 pm
by ViperZ
No new posts   Could it be my imagination? 6music1369View latest post on Tue Mar 17, 2020 2:51 pm
by PeterCapo
No new posts   Rectifier and blown fuse 5jimmeq506View latest post on Tue Mar 17, 2020 11:27 am
by Bob Latino
No new posts   VTA M125 transformer heater filament rating 2230 Ounce1200View latest post on Sat Mar 14, 2020 5:08 pm
by 30 Ounce
No new posts   Dynaco Pas Phono Input 3rudes499View latest post on Thu Mar 12, 2020 10:48 am
by rudes
No new posts   Add balanced input to M-125? 8ptstucky1120View latest post on Tue Mar 10, 2020 9:21 am
by Wotan
No new posts   PA060 No Load secondary HV tolerances 7BCROW623View latest post on Mon Mar 09, 2020 1:23 am
by BCROW
No new posts   Dee Pee Dave 17Tube Nube1090View latest post on Fri Mar 06, 2020 11:07 pm
by cci1492
No new posts   Stock MK III upgrade to octal driver boards? 6Adnick657View latest post on Wed Mar 04, 2020 5:57 pm
by Adnick
No new posts   My VTA ST-120 Just Arrived 2eminence1963797View latest post on Mon Mar 02, 2020 7:37 pm
by DavidR
No new posts   Help with Z565 3dmtparker1124View latest post on Wed Feb 26, 2020 10:46 pm
by murrayatuptown
No new posts   Power Transformer and AC wall voltage? 2music484View latest post on Wed Feb 26, 2020 5:42 pm
by PeterCapo
No new posts   Rebuilding Mark IIIs 1, 225OldFrisco1221View latest post on Wed Feb 26, 2020 1:12 am
by OldFrisco
No new posts   Guidance needed for a beginner - Mark II restoration ?'s 7JayMX679View latest post on Mon Feb 24, 2020 5:01 pm
by Jbacik
No new posts   How do you dust your equipment? 7chad1376486View latest post on Mon Feb 24, 2020 10:20 am
by Tom
Moderators
None
Permissions in this forum:
You cannot post new topics in this forum
You cannot reply to topics in this forum

Users browsing this forum: 0 Registered, 0 Hidden and 2 Guests

Registered Users: None


  • New posts New posts
  • No new posts No new posts
  • New posts [ Popular ] New posts [ Popular ]
  • No new posts [ Popular ] No new posts [ Popular ]
  • New posts [ Locked ] New posts [ Locked ]
  • No new posts [ Locked ] No new posts [ Locked ]
  • Announcement Announcement
  • Sticky Sticky
  • Global announcement Global announcement
Current date/time is Thu Aug 13, 2020 1:52 am