The Dynaco Tube Audio Forum

Dedicated to the restoration and preservation of all original Dynaco tube audio equipment - Customer support for Tubes4hifi VTA tube amp and preamp kits and all Dynakitparts.com products


Basket

TopicsRepliesAuthorViewsLast Posts
No new posts   ST-120, a storm, a power interruption and now "pops" 2antipodean453View latest post on Fri Feb 21, 2020 6:59 pm
by sKiZo
No new posts   Dynaco Marked EL34 Tubes 1rudes316View latest post on Thu Feb 20, 2020 3:41 pm
by tubes4hifi
No new posts   Differences / worthy upgrades from older VTA boards? 3calinet6453View latest post on Tue Feb 18, 2020 12:56 pm
by Bob Latino
No new posts   Back at it after awhile  0natoe220View latest post on Mon Feb 17, 2020 6:20 pm
by natoe
No new posts   Pavel's Auto Bias on Dynaco Mark III 8stewdan481View latest post on Mon Feb 17, 2020 3:05 pm
by pavlikkkk
No new posts   Unusual Dynaco / Scan-dyna speakers M-2 ? 0jives11172View latest post on Mon Feb 17, 2020 5:36 am
by jives11
No new posts   Testing KT77 & CV181 on a Hickok 752 tube tester 0breading187View latest post on Sat Feb 15, 2020 2:51 pm
by breading
No new posts   Are Matched Output Tubes Necessary with VTA ST-70? 14knotscott659View latest post on Fri Feb 14, 2020 5:26 pm
by peterh
No new posts   Speakers Pop on turnoff 6eminence1963296View latest post on Fri Feb 14, 2020 11:48 am
by eminence1963
No new posts   Opinions For Using Two VTA ST-70 As Monoblocks 1knotscott301View latest post on Fri Feb 14, 2020 11:31 am
by Wotan
No new posts   ST-120 Audio Circuit = floating ground? 4dalemurray343View latest post on Tue Feb 11, 2020 9:59 am
by dalemurray
No new posts   Edcor Transformers for Mark lll 15TN Allen962View latest post on Mon Feb 10, 2020 11:04 am
by TN Allen
No new posts   Added gold lion kt77 to my VTA st-70 and the lowest I can bias is .500 what can I do? 3leaveit_tubebeaver379View latest post on Sat Feb 08, 2020 9:07 pm
by Bob Latino
No new posts   Tube amps get pretty warm - especially in the summer (photo) 23Bob Latino9801View latest post on Fri Feb 07, 2020 12:26 am
by BillyW
No new posts   M125 - Red plating output tube 4costerdock290View latest post on Wed Feb 05, 2020 7:00 pm
by costerdock
No new posts   SP11 Preamp Just Arrived! 1, 22569Cutlass2323View latest post on Wed Feb 05, 2020 5:03 pm
by B&WTube
No new posts   Looking at the ST 70 Driver board but want to know if/what mods will conflict 1, 226bgovoni1008View latest post on Tue Feb 04, 2020 10:48 pm
by Jbacik
No new posts   PH-14 build, Any tips or advice? 7Mr C913View latest post on Tue Feb 04, 2020 8:14 pm
by tubes4hifi
No new posts   PH14 LED switch brightness 5Mr C395View latest post on Mon Feb 03, 2020 11:10 pm
by tubes4hifi
No new posts   Mark II Preamp Wiring Change Question 9AA6U533View latest post on Mon Feb 03, 2020 12:20 am
by AA6U
No new posts   ST-120 power tube red plate issue 13calauver11047View latest post on Sun Feb 02, 2020 5:47 pm
by markeby
No new posts   Very low bias and hum on Dynakit ST-70 1, 239lagwil2293View latest post on Sun Feb 02, 2020 12:48 pm
by lagwil
No new posts   Solid State Rectifier? 9music602View latest post on Sat Feb 01, 2020 3:11 pm
by rjpjnk
No new posts   ST120 KT88 bias for long life 1, 2, 367GreggW9161View latest post on Fri Jan 31, 2020 3:51 am
by GreggW
No new posts   Upgrading Power Cables and Fuses 1, 231B&WTube1682View latest post on Thu Jan 30, 2020 4:28 pm
by B&WTube
No new posts   How to tell if underpowered  12B&WTube759View latest post on Tue Jan 28, 2020 1:06 am
by B&WTube
No new posts   Variac Issue? 2music289View latest post on Mon Jan 27, 2020 5:01 pm
by music
No new posts   New VTA-70 Build - Right Channel Cutting Out After 10-15 Minutes - fixed ! 5knotscott368View latest post on Sat Jan 25, 2020 9:12 pm
by knotscott
No new posts   Did I blow my right output transformer? 8islanddave725View latest post on Fri Jan 24, 2020 1:29 pm
by Mr C
No new posts   Nordost Systems Solution 6Brap439View latest post on Thu Jan 23, 2020 11:20 am
by Brap
No new posts   Original Dynaco ST70 with VTA driver board - Bias Voltage Drops After a Few Minutes 10knotscott551View latest post on Mon Jan 20, 2020 9:18 am
by knotscott
No new posts   VTA ST-120 vs 2a3/300B 1music311View latest post on Sun Jan 19, 2020 10:44 am
by Bob Latino
No new posts   New product - VTA driver board cover (photo) 1, 2, 352Bob Latino10369View latest post on Sat Jan 18, 2020 6:24 pm
by ranges
No new posts   Best Rectifier and Driver Tubes for Latino VTA ST-70? 19Chris A2564View latest post on Wed Jan 15, 2020 12:41 pm
by Dave_in_Va
No new posts   Interconnects 1, 226tubenutr2266View latest post on Wed Jan 15, 2020 1:42 am
by MechEngVic
No new posts   Rectifier info  2Dave_in_Va267View latest post on Mon Jan 13, 2020 10:26 pm
by Dave_in_Va
No new posts   12X4 Rectifier Tube 4Sprags4153View latest post on Sun Jan 12, 2020 8:32 pm
by DavidR
No new posts   McIntosh MX 110 pre amp into VTA ST-70 4Udo496View latest post on Sun Jan 12, 2020 12:43 am
by Dogstar
No new posts   NOS and modern tubes 7deepee99793View latest post on Sat Jan 11, 2020 7:21 pm
by TN Allen
No new posts   power conditioning 13rymi1406View latest post on Sat Jan 11, 2020 6:59 pm
by aguaazul
No new posts   Dynaco ST70 bias issue - solved ! 9wrayman779View latest post on Sat Jan 11, 2020 4:52 pm
by wrayman
No new posts   RIP Roger Modjeski 0corndog71290View latest post on Fri Jan 10, 2020 10:22 pm
by corndog71
No new posts   Sad day! First VTA problem 3Dave_in_Va626View latest post on Fri Jan 10, 2020 10:27 am
by Dave_in_Va
No new posts   Dynaco SCA-35 output transformer question 4radiolandia293View latest post on Thu Jan 09, 2020 8:51 am
by radiolandia
No new posts   PH16X Hum/Buzz 1, 2, 353thermionicvinyl2683View latest post on Mon Jan 06, 2020 5:05 pm
by tubes4hifi
No new posts   M125 autobias hum, a ground issues? solved ! 3ericoto575View latest post on Mon Jan 06, 2020 4:57 pm
by tubes4hifi
No new posts   Mark lll Power Supply Transformer Temperature 2TN Allen356View latest post on Mon Jan 06, 2020 3:53 pm
by TN Allen
No new posts   Troubleshooting ST-70 Hum - now blowing fuses! Bad output transformer?  6bearwalker01701View latest post on Thu Jan 02, 2020 9:17 pm
by bearwalker01
No new posts   High B+ at 117 line voltage, Bad rectifier? 3intotubes470View latest post on Wed Jan 01, 2020 12:45 am
by rjpjnk
No new posts   Pre Amp? yes or not needed? 15music1368View latest post on Sat Dec 28, 2019 10:48 am
by audiobill
Moderators
None
Permissions in this forum:
You cannot post new topics in this forum
You cannot reply to topics in this forum

Users browsing this forum: 1 Registered, 0 Hidden and 4 Guests

Registered Users: Midwestside


  • New posts New posts
  • No new posts No new posts
  • New posts [ Popular ] New posts [ Popular ]
  • No new posts [ Popular ] No new posts [ Popular ]
  • New posts [ Locked ] New posts [ Locked ]
  • No new posts [ Locked ] No new posts [ Locked ]
  • Announcement Announcement
  • Sticky Sticky
  • Global announcement Global announcement
Current date/time is Mon May 25, 2020 8:30 pm